Несколько уязвимостей в службе IMAP в MailEnable

Дата публикации:
01.12.2006
Всего просмотров:
1296
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MailEnable Professional 1.x
MailEnable Enterprise Edition 1.x
MailEnable Enterprise Edition 2.x
MailEnable Professional 2.x
Уязвимые версии:
MailEnable Professional 1.6-1.83
MailEnable Enterprise Edition 1.1-1.40
MailEnable Enterprise Edition 2.0-2.33
MailEnable Professional 2.0-2.33

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

1. Уязвимость существует из-за ошибки проверки границ данных при обработке аргументов, передаваемых командам EXAMINE и SELECT в службе IMAP (MEIMAPS.EXE). Удаленный пользователь может с помощью слишком длинного аргумента вызвать переполнение буфера и выполнить произвольный код на целевой системе.

2. Уязвимость существует при обработке входных данных передаваемых команде DELETE в службе IMAP (MEIMAPS.EXE). Удаленный пользователь может вызвать переполнение стека путем отправки слишком длинного аргумента, содержащего символы "*" или "?".

URL производителя: www.mailenable.com

Решение: Установите исправление с сайта производителя.

Ссылки: MailEnable IMAP Service Two Vulnerabilities

или введите имя

CAPTCHA