Межсайтовый скриптинг в b2evolution

Дата публикации:
01.12.2006
Всего просмотров:
1245
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
b2evolution 1.x
Уязвимые версии: b2evolution 1.8.5, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "app_name" в сценариях _404_not_found.page.php, _410_stats_gone.page.php и _referer_spam.page.php, в праметре "baseurl" в сценарии _404_not_found.page.php и в параметре "ReqURI" в сценарии _referer_spam.page.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: b2evolution.net

Решение: Установите исправление с сайта производителя.

Ссылки: b2evolution XSS Vulnerability

или введите имя

CAPTCHA