Множественные уязвимости в P-News

Дата публикации:
01.12.2006
Дата изменения:
24.03.2009
Всего просмотров:
1337
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-6888
CVE-2006-7113
CVE-2006-7114
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
P-News 2.x
Уязвимые версии: P-News 2.0, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за некорректно установленных привилегий на доступ к файлу "db/user.txt". Удаленный пользователь может получить имена пользователей и MD5 хеши паролей. Пример:

http://[host]/path/db/user.txt

2. Уязвимость существует из-за недостаточной проверки расширений файлов при загрузке аватаров. Удаленный пользователь может загрузить и выполнить произвольный PHP сценарий на целевой системе.

URL производителя: download.planerd.net/dir/php

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA