Переполнение буфера в модуле mod_tls в ProFTPD

Дата публикации:
29.11.2006
Дата изменения:
06.02.2009
Всего просмотров:
2174
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ProFTPD 1.2.x
ProFTPD 1.3.x
Уязвимые версии: ProFTPD 1.3.0a, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных в функции "tls_x509_name_oneline()" в модуле contrib/mod_tls.c. Удаленный пользователь может послать серверу специально сформированные данные, вызвать переполнение буфера и выполнить произвольный код на целевой системе. Для удачной эксплуатации уязвимости приложение должно использовать модуль mod_tls.

URL производителя: www.proftpd.org

Решение: Установите последнюю версию 1.3.1rc1 с сайта производителя.

Ссылки: ProFTPD mod_tls pre-authentication buffer overflow

или введите имя

CAPTCHA