Переполнение буфера в ProFTPD

Дата публикации:
28.11.2006
Дата изменения:
06.02.2009
Всего просмотров:
3033
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ProFTPD 1.3.x
Уязвимые версии: ProFTPD 1.3.0 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в функции sreplace() в файле src/support.c. Удаленный авторизованный пользователь может вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.proftpd.org

Решение: Установите последнюю версию (1.3.0a) с сайта производителя.

Ссылки: ProFTPD remote buffer overflow vulnerability
ProFTPD 1.3.0 (sreplace) Remote Stack Overflow Exploit (meta)

или введите имя

CAPTCHA