Уязвимость форматной строки в GNU Radius

Дата публикации:
28.11.2006
Дата изменения:
28.11.2006
Всего просмотров:
1199
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU Radius 1.x
Уязвимые версии: GNU Radius 1.3 и более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки форматной строки в функции "sqllog()". Удаленный пользователь может послать приложению специально сформированную строку и выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости GNU Radius должен быть собран с поддержкой SQL и SQL-эккаунтинг должен быть разрешен.

URL производителя: www.gnu.org/software/radius/radius.html

Решение: Установите последнюю версию (1.4) с сайта производителя.

Ссылки: GNU Radius Format String Vulnerability

или введите имя

CAPTCHA