PHP-инклюдинг в Photo Cart

Дата публикации:
28.11.2006
Всего просмотров:
1230
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Photo Cart 3.x
Уязвимые версии: Photo Cart 3.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "admin_folder" и "path" в сценарии adminprint.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/PhotoCart/adminprint.php?admin_folder=[file]
http://[host]/PhotoCart/adminprint.php?path=[file]

URL производителя: www.picturespro.com/pages/photography_shopping_cart/index.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Photo Cart 3.9 (adminprint.php) Remote File Include Vulnerability

или введите имя

CAPTCHA