SQL-инъекция в PSCRIPT Forum

Дата публикации:
21.11.2006
Дата изменения:
15.09.2008
Всего просмотров:
1509
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Powies PSCRIPT Forum 1.x (PForum)
Уязвимые версии: Powies PSCRIPT Forum (PForum) 1.29a, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "id" в сценарии editpoll.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://[host]/editpoll.php?id=[SQL]

URL производителя: www.pscript.de

Решение: Установите последнюю версию 1.30 с сайта производителя.

Ссылки: Powies pForum <= 1.29a (editpoll.php) SQL Injection Vulnerability

или введите имя

CAPTCHA