PHP-инклюдинг в PHPQuickGallery

Дата публикации:
21.11.2006
Всего просмотров:
1072
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHPQuickGallery 1.x
Уязвимые версии: PHPQuickGallery 1.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "textFile" в сценарии phpquickgallery/gallery_top.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/phpquickgallery/gallery_top.inc.php?textFile=[file]

URL производителя: www.icefox.net/programs/?program=PHPQuickGallery

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PHPQuickGallery <= 1.9 (textFile) Remote File Include Vulnerability

или введите имя

CAPTCHA