SQL-инъекция в FunkyASP Glossary

Дата публикации:
17.11.2006
Дата изменения:
17.11.2006
Всего просмотров:
3167
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FunkyASP Glossary 1.x
Уязвимые версии: FunkyASP Glossary 1.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "alpha" в сценарии glossary.asp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://site.com/glossary/glossary.asp?alpha='[sql]

URL производителя: www.funkyasp.co.uk

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA