Переполнение буфера в libpng

Дата публикации:
17.11.2006
Дата изменения:
28.10.2008
Всего просмотров:
1471
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
libpng 1.x
Уязвимые версии: libpng 1.2.12, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки проверки границ данных в функции "png_set_sPLT()" в файле pngset.c. Удаленный пользователь может с помощью специально сформированного PNG файла вызвать отказ в обслуживании приложения.

URL производителя: www.libpng.org

Решение: Установите последнюю версию (1.2.13) с сайта производителя.

Ссылки: http://bugs.gentoo.org/show_bug.cgi?id=154380

или введите имя

CAPTCHA