PHP-инклюдинг в phpPeanuts

Дата публикации:
17.11.2006
Дата изменения:
24.03.2009
Всего просмотров:
992
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpPeanuts 1.x
Уязвимые версии: phpPeanuts 1.2.0, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "Include" в сценарии pntUnit/Inspect.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/[phppeanuts_path]/pntUnit/Inspect.php?Include=[file]

URL производителя: www.phppeanuts.org

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: phpPeanuts 1.3 Beta (Inspect.php) Remote File Include Vulnerability

или введите имя

CAPTCHA