Переполнение буфера в RPM

Дата публикации:
06.11.2006
Всего просмотров:
1899
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
RPM Package Manager 4.x
Уязвимые версии: RPM Package Manager 4.x

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке определенных RPM пакетов. Удаленный пользователь может с помощью специально сформированного RPM пакета вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе. Для удачной эксплуатации уязвимости должны быть выставлены определенные локали (например, ru_RU.UTF-8).

URL производителя: rpm.org

Решение: Установите исправление из CVS репозитория производителя.

Ссылки: CVE-2006-5466 RPM Crash after listing contents of non-installed package

или введите имя

CAPTCHA