PHP-инклюдинг в phpDynaSite

Дата публикации:
06.11.2006
Всего просмотров:
2749
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpDynaSite 3.x
Уязвимые версии: phpDynaSite 3.2.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "racine" в сценариях function_log.php, function_balise_url.php и connection.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[target]/[path]/function_log.php?racine=[file]
http://[target]/[path]/function_balise_url.php?racine=[file]
http://[target]/[path]/connection.php?racine=[file]

URL производителя: sourceforge.net/projects/phpdynasite/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: phpDynaSite <= 3.2.2 (racine) Remote File Include Vulnerabilities

или введите имя

CAPTCHA