SQL-инъекция в PHP-Nuke

Дата публикации:
02.11.2006
Всего просмотров:
5358
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP-Nuke 7.x
Уязвимые версии: PHP-Nuke 7.9, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "forwhat" в сценарии modules/journal/search.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения. Пример:

http://victim/moblog/big.php?img=[SQL]&pg=1

URL производителя: www.phpnuke.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PHP-Nuke <= 7.9 Journal module (search.php) "forwhat" SQL Injection vulnerability

или введите имя

CAPTCHA