Инклюдинг локальных файлов в PunBB

Дата публикации:
31.10.2006
Всего просмотров:
13039
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-5735
CVE-2006-5736
CVE-2006-5737
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PunBB 1.x
Уязвимые версии: PunBB 1.2.13, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю просмотреть содержимое произвольных файлов на системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "language" в сценарии register.php в процессе регистрации пользователя. Удаленный пользователь может с помощью специально сформированного запроса просмотреть содержимое произвольных файлов на системе.

URL производителя: www.punbb.org

Решение: Установите последнюю версию (1.2.14) с сайта производителя.