Уязвимость при обработке UTF-8 символов в GNU Screen

Дата публикации:
25.10.2006
Всего просмотров:
1930
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GNU Screen 4.x
Уязвимые версии: GNU Screen версии до 4.0.3.

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки при обработке определенных UTF-8 символов. Удаленный пользователь может вывести специально сформированную строку в окне и вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

URL производителя: www.gnu.org/software/screen/screen.html

Решение: Установите последнюю версию (4.0.3) с сайта производителя.

Ссылки: Secfix release for screen: screen-4.0.3

или введите имя

CAPTCHA