PHP-инклюдинг в Mambo MambWeather

Дата публикации:
24.10.2006
Дата изменения:
24.10.2006
Всего просмотров:
1842
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MambWeather 1.x (модуль к Mambo)
Уязвимые версии: MambWeather (модуль к Mambo) 1.8.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "mosConfig_absolute_path" в сценарии modules/MambWeather/Savant2/Savant2_Plugin_options.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[site]/[path_to_mambo]/modules/MambWeather/Savant2/Savant2_Plugin_options.php?mosConfig_absolute_path=[file]

URL производителя: mamboxchange.com/projects/myweather/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: MambWeather Mambo Module <= 1.8.1 Remote Include Vulnerability

или введите имя

CAPTCHA