PHP-инклюдинг в CDS Agenda

Дата публикации:
24.10.2006
Всего просмотров:
1057
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CDS Agenda 4.x
Уязвимые версии: CDS Agenda 4.2.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "AGE" в сценарии modification/SendAlertEmail.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/cdsagenda/modification/SendAlertEmail.php?AGE=[file]

URL производителя: cdsware.cern.ch/agenda/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Cdsagenda <= 4.2.9 (SendAlertEmail.php) File Include Vulnerability

или введите имя

CAPTCHA