PHP-инклюдинг в Open Conference Systems

Дата публикации:
24.10.2006
Всего просмотров:
1057
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Open Conference Systems 1.x
Уязвимые версии: Open Conference Systems 1.1.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "fullpath" в сценариях include/themes.inc.php и include/footer.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/ocs/include/theme.inc.php?fullpath=[file.gif]
http://[host]/ocs/include/footer.inc.php?fullpath=[file.gif]

URL производителя: pkp.sfu.ca/?q=ocs

Решение: Установите последнюю версию (1.1.6) с сайта производителя.

Ссылки: Open Conference Systems <= 1.1.3 (fullpath) File Include Vulnerabilities

или введите имя

CAPTCHA