PHP-инклюдинг в NuralStorm Webmail

Дата публикации:
24.10.2006
Всего просмотров:
904
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NuralStorm Webmail 0.x
Уязвимые версии: NuralStorm Webmail 0.98b, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "DEFAULT_SKIN" в сценарии process.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[path]/process.php?DEFAULT_SKIN=[file]

URL производителя: www.nuralstorm.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: NuralStorm Webmail <= 0.98b Remote File Include Vulnerability

или введите имя

CAPTCHA