Множественные уязвимости в Drupal

Дата публикации:
23.10.2006
Всего просмотров:
2108
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-5475
CVE-2006-5476
CVE-2006-5477
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Внедрение в сессию пользователя
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal 4.x
Уязвимые версии: Drupal версии до 4.6.10 и 4.7.4

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS и CSRF атаки.

1. Уязвимость существует из-за недостаточной проверки входных данных в XML обработчике. Удаленный пользователь может с помощью специально сформированного RSS канала выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости PHP расширение "mbstring" должно быть отключено.

2. Уязвимость существует из-за недостаточной обработки входных данных в модулях "aggregator", "profile" и "forum". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за того, что приложение позволяет пользователю произвести некоторые действия посредством HTTP запроса без проверки подлинности пользователя. Злоумышленник может сменить пароль, опубликовать PHP код или создать нового пользователя.

4. Уязвимость существует из-за недостаточной обработки входных данных. Злоумышленник может с помощью специально сформированной ссылки перенаправить пользователя на злонамеренный сайт.

URL производителя: drupal.org

Решение: Установите последнюю версию (4.6.10 или 4.7.4 и выше) с сайта производителя.

или введите имя

CAPTCHA