PHP-инклюдинг в LoCal Calendar System

Дата публикации:
20.10.2006
Дата изменения:
20.10.2006
Всего просмотров:
2270
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
LoCal Calendar System 1.x
Уязвимые версии: LoCal Calendar System 1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "LIBDIR" в сценарии lib/lcUser.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/lib/lcUser.php?LIBDIR=[file]

URL производителя: www.loci.wisc.edu/calendar/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: LoCal Calendar 1.1 (lcUser.php) Remote File Include Vulnerability

или введите имя

CAPTCHA