Множественные уязвимости в Bugzilla

Дата публикации:
17.10.2006
Дата изменения:
05.05.2008
Всего просмотров:
2399
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-5453
CVE-2006-5454
CVE-2006-5455
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Bugzilla 2.x
Уязвимые версии: Bugzilla 2.x

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных полях форм, и при наличии тегов h1 и h2. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за ошибки при просмотре вложений в режиме "diff". Удаленный пользователь, который не является членом группы "insidergroup", может просмотреть описание всех вложений. Также, при импорте данных в XML формат, поле "deadline" доступно для просмотра пользователям, которые не являются членами группы "timetrackinggroup". Удаленный пользователь может получить доступ к важным данным.

3. Bugzilla позволяет пользователям произвести определенные действия посредством HTTP GET и POST запросов без достаточной проверки входных данных. Злоумышленник может изменить, удалить и добавить данные об уязвимости.

4. Уязвимость существует из-за недостаточной обработки входных данных в сценарии showdependencygraph.cgi. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.bugzilla.org

Решение: Установите последнюю версию (2.18.6, 2.20.3, 2.22.1 или 2.23.3) с сайта производителя.
Примечание: уязвимость #3 исправлена только в версиях 2.22.1 и 2.23.3

Ссылки: Bugzilla 2.18.5, 2.20.2, 2.22, and 2.23.2 Security Advisory

или введите имя

CAPTCHA