Несколько уязвимостей в обработке входных данных в Flatnuke

Дата публикации:
12.10.2006
Дата изменения:
17.10.2006
Всего просмотров:
1435
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
FlatNuke 2.x
Уязвимые версии: Flatnuke 2.5.8, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным, повысить свои привилегии в приложении и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "userlang" в сценарии header.php. Удаленный пользователь может с помощью специально сформированного запроса просмотреть содержимое произвольных файлов на системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "file_da_canc" в сценарии sections/none_Sondaggio/Vecchi_sondaggi/sections.php. Используя уязвимость #1 злоумышленник может удалить произвольные файлы на системе.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "myforum" в файле куки в механизме аутентификации. Удаленный пользователь может загрузить и выполнить произвольный PHP сценарий на целевой системе.

URL производителя: www.flatnuke.org

Решение: Установите последнюю версию с сайта производителя.


или введите имя

CAPTCHA