Недостаточная обработка входных данных в Softerra PHPLibrary

Дата публикации:
12.10.2006
Дата изменения:
17.10.2006
Всего просмотров:
1419
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Softerra PHPLibrary 1.x
Уязвимые версии: Softerra PHPLibrary 1.5.3, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "lib_dir" в сценариях lib/registry.lib.php, lib/sqlcompose.lib.php и sqlsearch.lib.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера.

URL производителя: www.softerra.com/products_php-library.htm

Решение: Способов устранения уязвимости не существует в настоящее время.


или введите имя

CAPTCHA