PHP-инклюдинг в OpenDock Easy Gallery

Дата публикации:
10.10.2006
Дата изменения:
17.10.2006
Всего просмотров:
1193
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenDock Easy Gallery 1.x
Уязвимые версии: OpenDock Easy Gallery 1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "doc_directory" в различных сценариях. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/sw/lib_up_file/file.php?doc_directory=[file]
http://[host]/sw/lib_comment/comment.php?doc_directory=[file]
http://[host]/sw/lib_session/session.php?doc_directory=[file]
http://[host]/sw/lib_user/user.php?doc_directory=[file]

URL производителя: web.opendock.net/index.php/ln/en/id_p/48.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: OpenDock Easy Gallery <=1.4 (doc_directory) Multiple Remote File Inclusion Vulnerability

или введите имя

CAPTCHA