Межсайтовый скриптинг в веб приложении для электронной коммерции CubeCart

Дата публикации:
29.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
2699
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-5107
CVE-2006-5108
CVE-2006-5109
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CubeCart 2.x
Уязвимые версии: CubeCart 2.0.7, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/admin/nav.php?site_url=[code]
http://[host]/admin/nav.php?la_search_home=[code]
http://[host]/admin/header.inc.php?site_name=[code]
http://[host]/admin/header.inc.php?la_adm_header=[code]
http://[host]/admin/header.inc.php?charset=[code]
http://[host]/footer.inc.php?la_pow_by=[code]

Ветка 3.x не подвержена этой уязвимости.

URL производителя: www.cubecart.com

Решение: Способов устранения уязвимости не существует в настоящее время.


или введите имя

CAPTCHA