PHP-инклюдинг в сценарии для публикации новостей Newswriter

Дата публикации:
29.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
6204
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Newswriter 1.x
Уязвимые версии: Newswriter 1.42, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "NWCONF_SYSTEM[server_path]" в сценарии include/editfunc.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.baumedia.net/newswriter.0.html

Решение: Способов устранения уязвимости не существует в настоящее время.


или введите имя

CAPTCHA