PHP-инклюдинг в системе управления содержанием WEB//NEWS

Дата публикации:
28.09.2006
Дата изменения:
17.10.2008
Всего просмотров:
2502
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WEB//NEWS 1.x
Уязвимые версии: WEB//NEWS 1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "WN_BASEDIR" в сценарии parse/parser.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[scerpitPath]/parse/parser.php?WN_BASEDIR=[file]

URL производителя: stylemotion.de/engine.php?show=webnews

Решение: Установите последнюю версию 1.4 с сайта производителя.

Ссылки: WEB//NEWS <= 1.4 (parser.php) Remote File Include Vulnerability

или введите имя

CAPTCHA