PHP-инклюдинг в приложении для создания блогов A-Blog

Дата публикации:
28.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
1934
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-5092
CVE-2008-0676
CVE-2008-0677
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
A-Blog 2.x
Уязвимые версии: A-Blog 2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "navigation_start" в сценарии navigation/menu.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/ablog_dir/navigation/menu.php?navigation_start=[file]

URL производителя: sourceforge.net/projects/a-blog/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: A-Blog V2 (menu.php) Remote File Include Vulnerability

или введите имя

CAPTCHA