PHP-инклюдинг в Веб приложении для он лайн опросов phpQuestionnaire

Дата публикации:
27.09.2006
Дата изменения:
24.03.2009
Всего просмотров:
2345
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpQuestionnaire 3.x
Уязвимые версии: phpQuestionnaire 3.12, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[phpQRootDir]" в сценарии inc/ifunctions.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/path_to_phpQuestionnaire/inc/
ifunctions.php?GLOBALS[phpQRootDir]=[file]

URL производителя: www.chumpsoft.com/products/phpq/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: phpQuestionnaire 3.12 (GLOBALS[phpQRootDir]) Remote File Inclusion

или введите имя

CAPTCHA