Межсайтовый скриптинг в DotNetNuke

Дата публикации:
25.09.2006
Дата изменения:
07.05.2008
Всего просмотров:
2032
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DotNetNuke 3.x
DotNetNuke 4.x
Уязвимые версии: DotNetNuke версии до 3.3.5 и 4.3.5.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "error" в сценарии Default.aspx. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Пример:

http://[host]/Default.aspx?tabid=510&error=[code]

URL производителя: www.dotnetnuke.com

Решение: Установите последнюю версию с сайта производителя.

Ссылки: HTML Code Injection Vulnerability

или введите имя

CAPTCHA