Несколько уязвимостей в Limbo

Дата публикации:
21.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
1625
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Limbo 1.x
Уязвимые версии: Limbo 1.0.4.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "classes_dir" в сценарии classes/adodbt/sql.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "lm_absolute_path" и "install_dir" в сценариях admin/components/com_fm/fm.install.php и components/com_fm/fm.install.php при удалении или копировании файлов. Удаленный пользователь может удалить произвольные файлы или изменять содержимое файла fm.english.php. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

Также, злоумышленник может создать пустые файлы на системе и получить данные об установочной директории приложения.

URL производителя: www.limboforge.org

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA