PHP-инклюдинг в MobilePublisherPHP

Дата публикации:
21.09.2006
Всего просмотров:
5932
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MobilePublisherPHP 1.x
Уязвимые версии: MobilePublisherPHP 1.5 RC2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "abspath" в сценарии header.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[dir]/header.php?abspath=[file]

URL производителя: webscript.ru

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: MobilePublisherPHP <= 1.5 RC2 Remote File Include Vulnerability

или введите имя

CAPTCHA