Межсайтовый скриптинг в Roller Weblogger

Дата публикации:
21.09.2006
Дата изменения:
12.01.2009
Всего просмотров:
931
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Roller Weblogger 2.x
Уязвимые версии: Roller Weblogger 2.3, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в полях "name", "email" и "url" при публикации комментария. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: rollerweblogger.org/project/

Решение: Установите последнюю версию (2.3.1-rc1) с сайта производителя.

Ссылки: Safe comments: strip HTML from comment name, URL and email addresses
http://www.kb.cert.org/vuls/id/366900
http://opensource.atlassian.com/projects/roller/browse/ROL-1196

или введите имя

CAPTCHA