Множественные уязвимости в gzip

Дата публикации:
20.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
2212
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-4334
CVE-2006-4335
CVE-2006-4336
CVE-2006-4337
CVE-2006-4338
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
gzip 1.x
Уязвимые версии: gzip 1.3.5, возможно более ранние версии.

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании или скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки разыменования нулевого указателя в функции "huft_build()". Удаленный пользователь может с помощью специально сформированного архива вызвать отказ в обслуживании приложения.

2. Уязвимость существует из-за ошибки индекса массива в функции make_table в файле unlzh.c при обработке LZH архивов. Удаленный пользователь может с помощью специально сформированного архива вызвать переполнение буфера и выполнить произвольный код на целевой системе.

3. Переполнение буфера существует в функции build_tree в файле unpack.c. Удаленный пользователь может с помощью специально сформированной таблицы записать отрицательное значение индекса и выполнить произвольный код на целевой системе.

4. Переполнение буфера обнаружено в функции make_table в компоненте LHZ. Удаленный пользователь может создать специально сформированную таблицу декодирования архива и выполнить произвольный код на целевой системе.

5. Уязвимость существует в файле unlzh.c в компоненте LHZ. Злоумышленник может с помощью специально сформированного архива вызвать зацикливание приложения и потребить все доступные ресурсы на системе.

Решение: Установите исправленную версию от производителя.

или введите имя

CAPTCHA