PHP-инклюдинг в phpBB XS

Дата публикации:
19.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
22961
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpBB XS 0.x
Уязвимые версии: phpBB XS 0.58, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "phpbb_root_path" в сценарии bb_usage_stats/includes/bb_usage_stats.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[path]/bb_usage_stats/include/bb_usage_stats.php?phpbb_root_path=[file]

URL производителя: www.phpbbxs.eu

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: phpBB XS (phpbb_root_path) Remote File Include

или введите имя

CAPTCHA