PHP-инклюдинг в TeamCal

Дата публикации:
18.09.2006
Дата изменения:
24.03.2009
Всего просмотров:
1531
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TeamCal Pro 2.x
Уязвимые версии: TeamCal 2.8.001, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "tc_config[app_root]" в сценарии includes/footer.html.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/path/includes/footer.html.inc.php?tc_config[app_root]=[file]

URL производителя: www.lewe.com/index.php?option=com_content&task=view&id=107&Itemid=42

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: TeamCal Pro <= 2.8.001 (app_root) Remote file Include Vulnerability

или введите имя

CAPTCHA