Обход ограничений безопасности в GnuTLS

Дата публикации:
18.09.2006
Всего просмотров:
1126
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuTLS 1.x
Уязвимые версии: GnuTLS 1.4.2, возможно более ранние версии.

Описание:
Уязвимость позволяет удаленному пользователю обойти некоторые ограничения безопасности.

Уязвимость существует из-за ошибки при проверке подлинностей некоторых подписей. Если используется RSA ключ с экспонентой 3, злоумышленник может подделать PKCS #1 v1.5 подписи к ключу. Уязвимость относится к:
Обход ограничений безопасности в OpenSSL

URL производителя: www.gnu.org/software/gnutls/

Решение: Установите последнюю версию (1.4.4) с сайта производителя.

Ссылки: Variant of Bleichenbacher's crypto 06 rump session attack

или введите имя

CAPTCHA