PHP-инклюдинг в Quicksilver Forums

Дата публикации:
14.09.2006
Дата изменения:
28.11.2008
Всего просмотров:
2449
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Quicksilver Forums 1.x
Уязвимые версии: Quicksilver Forums 1.2.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "set[include_path]" в сценарии lib/activeutil.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/lib/activeutil.php?set[include_path]=[file]

URL производителя: quicksilverforums.com

Решение: Установите последнюю версию 1.3.0 с сайта производителя.

Журнал изменений:

28.11.2008
Изменено описание уязвимости.

или введите имя

CAPTCHA