PHP-инклюдинг в MySpeach

Дата публикации:
08.09.2006
Дата изменения:
24.03.2009
Всего просмотров:
1009
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MySpeach 3.x
Уязвимые версии: MySpeach 3.0.2, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "my_ms[root]" в сценарии jscript.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[Script Path]/jscript.php?my_ms[root]=[file]

URL производителя: www.myspeach.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
24.03.2009
Изменена секция "Решение"

Ссылки: MySpeach <= 3.0.2 (my_ms[root]) Remote File Include Vulnerability

или введите имя

CAPTCHA