PHP-инклюдинг в GrapAgenda

Дата публикации:
08.09.2006
Всего просмотров:
823
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GrapAgenda 0.x
Уязвимые версии: GrapAgenda 0.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "page" в сценарии index.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/[agendapath]/index.php?page=[file.txt]?&cmd=id

URL производителя: www.graphiks.net/scripts-php/script-2-20-0.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: [Kurdish Security # 25 ] GrapAgenda Remote Command Vulnerability

или введите имя

CAPTCHA