PHP-инклюдинг в C-News

Дата публикации:
08.09.2006
Всего просмотров:
1015
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
C-News 1.x
Уязвимые версии: C-News 1.0.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "path" в различных сценариях. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/affichage/commentaires.php?path=[file]
http://[host]/affichage/formulaire_commentaires.php?path=[file]
http://[host]/affichage/liste_news.php?path=[file]
http://[host]/affichage/news_complete.php?path=[file]
http://[host]/affichage/pagination.php?path=[file]

URL производителя: www.c-news.fr

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: C-News <= 1.0.1 (path) Remote File Inclusion Vulnerability

или введите имя

CAPTCHA