Отказ в обслуживании в GDB

Дата публикации:
05.09.2006
Всего просмотров:
1709
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GDB 6.x
Уязвимые версии: GDB 6.x

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки проверки границ данных при обработке DWARF и DWARF2. Удаленный пользователь может с помощью специально сформированного файла, просматриваемого с помощью GDB, выполнить произвольный код на целевой системе.

URL производителя: www.gnu.org/software/gdb/gdb.html

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: CVE-2006-4146 GDB buffer overflow

или введите имя

CAPTCHA