PHP-инклюдинг в phpECard

Дата публикации:
31.08.2006
Дата изменения:
17.10.2006
Всего просмотров:
1529
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2006-4456
CVE-2006-4457
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpECard 2.x
Уязвимые версии: phpECard 2.1.4, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "include_path" в сценарии functions.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Пример:

http://[host]/[Script Path]/functions.php?include_path=[file]

URL производителя: www.quick-xs.net/phpecard/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: phpECard <= 2.1.4 (functions.php) Remote File Include Vulnerability

или введите имя

CAPTCHA